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Getting started
« Go to Longhorn portal:

 Sign in using your XSEDE
credentials

1/20/2012

TAGG XSEDE Longhorn Visualization Portal
Home | Allocations | Jobs | Help

Wel to the Longhorn Visualization Portal!

bbbbbbbbbbbb

System Requirements:

«' JavaScript & Java applets Enabled
v Java 142+
</ Windowe: Eirafoy 2+



http://portal.longhorn.tacc.utexas.edu/
http://portal.longhorn.tacc.utexas.edu/

Cornell University

Center for Advanced Computing

Set your VNC password

* Click “here” to set/change
your VNC PaSSWOo rd TAGG XSEDE  Longhom Visuaization Portal e

Start a Job

— This is exactly equivalent 77
t0 using vncpasswd oOn e e S

HNumber of nedes: (2 ¥

Wayriess (processes per node): |4 ¥

the command line U

— If you forget to do this, and C |
nave never set the vnc o

el apphcation is executed
Lenghaen {longhom face utexas. edu), TACC's Dell XD Visuakzation Cluster, contains 2048 compule cores, 14.5 T aggregate memory and 512 GPUs, Longhom has a GOR
InfiniBand interconnect and has an atiached Lustre parallel fie system. Longhom is connacted by 10GIgE 1o Ranger's Lusire parallel fle system ihus making il mere

.
cemveniant to work on datasets generated on Ranger. Longhom has 256 nodes + 2 login nodes, with 240 nodes containing 48GB of RAM, 8 Intel Nehalem cores (& 25
aS SWO r e O r e O l I WI GHz), and 2 NVIDIA Quadre FX 5800 GPUs. Longhom also has an additienal 16 large-memory nodes contamng 144GB of RAM, B Intel Nehalem cores @ 25 GHz), and 2
’ MADLA Quaden FX 5800 GPUs. For mere detaited infarmation on Longhern, please see the L ser Gu
Qurewre information:

be prompted. Don’t worry

The Langhoin quéuss are opén

\ ‘ 125 nodes available out of 250 total

Resources

ACTIVE JOBS=mmmmmmmmmmmmeemmmenm———e
J0EID JOENANE  USERNAME STATE CORE REMATNING STARTTINE
12244€ Hadooply  lwowen Bunning 40 S Sun Jan 8 11:07:01
122483 iq_maa0007 lacs Bunning 128 8 Sun Jam 8 11
122504 16 980008 Lazs Punnisg 128 9 Sun Jan @
2509 1q =aa0005 lars Funnieg 128 Sun Jan 8
2510 iq mas0010 lars Funning 128 S Sun Jan @
511 b blot ing Funning £4 S Sun Jan @ E
22512 bloring Bunnino £4 8 Sun Jdan 8 X

1/20/2012 3
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Set your VNC password

« Enter a password in the
window that pops up.
Click “Set VNC password”
button, then close
— Do NOT use an important

(e.g. login) password for
this!! Remember, VNC
passwords protect a
running session only, and
might be shared with
others

1/20/2012

TAGG XSEDE Longhorn Visualization Portal
Home || Allocations | Jobs | Help

Processing

Available Resources

« Longhorn

Longhom (lengher.tace. utexas. edu), TACC's Dell XD Visualization Cluster, contains 2048 compute cores, 145 T8 aggregate memory and 512 GPUs, Langhom has a O
interconnzct and has an attached Lustre parallel file system. Longhom is connected by 10GigE to Ranger's Lustre parallel fils system thus making it more convenient to w
generated on Ranger. Longhom has 256 nodes +2 login nedes, with 240 nodes containing 48GB of RAM, 8 Intel Nehalem cores (@ 2.5 GHz), and 2 NVIDIA Quadro FX 5
also has an additional 16 large-memory nodes containing 144GB of RAM, & Intel Nehalem cores (@ 2.5 GHz), and 2 NVIDIA Quadro FX 5800 GPUs. For more detailed inf
please see the Langhom User Guide.

Queue information:

Set UNC Password x
updated at January 8, 2012, 4:32:48 pm (refresh)

Password: eeereees

Available— . TneLonghom qususs are o] Re-enter: sssssssees
Used 242 nodes available out of 2
Passwords match!
SetVNC Password
ACTIVE JOBS-———————————————— oo
JOBID JOBNANE USERNAME STATE CCORE REM,
12244€ Hadooplw lwowsn Running 40 18:34:12 Sun Jan 8 11:07:01
122535 Hadeoop-tes roller Bunning 24 04:40:12 Sun Jan 8 15:13:01
2 active jobs : 8 of 248 hosts ( 3.23 %)

WAITING JOBS—mmmmmmmmmm oo mmmmo e
(s JOBNANE USERNAME STATE ~ CORE WCLIMIT QUEUETIME

VAITING JOBS WITH JOB DEPENDENCIES--—
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Start a VNC session

Make sure VNC session
type is selected T

S Ify b f nod
—
—
. )
—
—
. Longhom (longhorn tace. utexas. edu}, TACC's Dell XD Visualization Cluster, contains 2048 compute cores, 14.5 TB aggregate memory and 512 GPUs. Longharn has a GDR
11 b} InfiniBand interconnect and has an attached Lustre parallel file system. Longhorn is connected by 10GigE to Rangers Lustre parallel file system thus making it more
[ ) convenient to work on datasets generated on Ranger. Longhorn has 256 nodes + 2 login nodes, with 240 nodes containing 48GB of RAM, 8 Intel Nehalem cores (@ 2.5
GHz), and 2 NVIDIA Quadro FX 5800 GPUs. Longhorn also has an additional 16 large-memary nodes containing 144GB of RAM, 8 Intel Nehalem cores (@ 2.5 GHz), and 2

NVIDIA Quadro FX 5800 GPUs. For more detailed information on Longhom, please see the Longhom User Guide.

XSEDE\apb18 logout

n Visualization Portal No job running

facations | Jobs || Help

Start a Job

Resource: |Longhorn ¥

Sessiontype: © VNC ' EnVision guided visualization

1280x1024 v
2 v

Desktop resolution
Number of nodes

Wayness (processas per node): 4 7

Note: increasing the number of nodes will only increase
: e.g

Visli). The wayness parameter is only relevant to paralel
applications, and determines how many processes are
spavined per node when the parallel application is executed.

Click here to set your VNC password

Available R

« Longhom

Queue information:

updated at January 8, 2012, 12:34:41 pm (refresh)

Available——————

The Longhorm queues are open

125 nodes available out of 250 total
u:nu¥’

ACTIVE JOBS
OEID JOENAME USERNAKE STATE ~ CORE REMAINING STARTTIME

246 Hadooplw  lwowen Running 40 119 Sun Jan 8
283 iq_mss0007 lars Running 128 18 Sun Jan 8
504 iq mss0008 lars Funning 128 118 Sun Jan 8
509 iq mss0009 lars Running 128 9:19 Sun Jan 8
510 iq mss00L0 lars Running 128 18 Sun Jan 8
511  bz-19500 bloring Punning 64 118 Sun Jan 8 [
12 Bz-1 Bloring Bunning &4 119 Sun Jan =

1/20/2012 5
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Start a VNC session

* When “Start” is clicked,
the portal Wl” TAGG XSEDE  Longhom Visualization Portal s o

Home || Allocations | Jobs | Help

automatically submita job

Available Resources

- « Longhom
V I a q S l I Longham (longhorn.tace.utexas. edu), TACC's Dell XD Visualization Cluster, contains 2048 compute cores, 14.5 TB aggregate memory and 512 GPUs, Longhom has a GDR
- i

InfiniBand interconnect and has an attached Lustre parallel file system. Longhorn is connected by 10GigE to Ranger's Lustre parallel file system thus making it more
convenient to work on datassts generated on Ranger. Langhorn has 256 nodes + 2 login nodes, with 240 nodes containing 48GB of RAM, 8 Intel Nehalem cores (@ 2.5
GHz), and 2 NVIDIA Quadro FX 5800 GPUs. Longhorn also has an additional 16 large-memary nodes containing 144GB of RAM, 8 Intel Nehalem cores (@ 2.5 GHz), and 2
NVIDIA Quadro FX 5800 GPUs. For more detailed infarmation on Longhom, please see the Longhorn User Guide

 You will see status on i

Available——————

Velcome to TACC's Longhorn Visualismavien Sysvem, sn NS KD Resource —----

screen. It may take a little s == f
while to go from Queued

446 Hadooplw  lwower
283 iq_wmes0007 lars
504 1q mssO008 lars
509 iq_mss0009 lars

> Ensuzing absence of duhious B vmemh_dava,s_vmem,s_daca Liniva...

> Requesting val id memozy configuation (me=1L.36)..
510 iqmss0010 lars LTty 0 G ¢ )
B 310 ENeenCiD AarS | o> Ueritying KOE file-sysem availsbiticy. . <
512 Bloril| --> Vesitying SCRAICH £ile-systen svailshil icy
513 B16T41| > checking ssh sevup.
514 blors
-> Cheching that you didn't cequest more cores than the maximm...

L] 518 blordil | e y N . don 1“‘3 = 3" wnber of jobs

He PLOE L] o> Checking shas you don'e slzesdy Bave the musimn renbes of gons

> Checking chae yous time limit isn'e ever vhe musimn...
> Checking availdble allocasion.

12 active Jobs 125 (| —y sumiceing eb
VAITING JOBS-—----------——
OF JOBNAME ~ USERN,| Yeus job 1

4 ("poscal_wnc') has heen sbmiveed

huijii| Job status is Queued

bloril

bloring weTcTng T oTT e

bloring Vaiting 64 0 Sun Jan

bloring Vaiting &4 0 Sun Jan =
bz-3500  bloring Vaiting 64 olL: Sun Jan

VAITING JOBS WITH JOB DEPENDENCIES-—-
JOBID JOBNAME USERNANE STATE ~ CORE WCLIMIT  QUEUETINE

UNSCHEDULED JCBS

1/20/2012
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Start a VNC session

* A VNC session is how
running. By default, you ~ TASCXSEDE tenatomVeualzatonforta
are brought to a
“rendering” tab which has
a built-in VNC viewer.
You can use this if you
wish, or just use your own
VNC client.

* Type in your VNC
password to access the
session.

sssssssssssssssss

1/20/2012 7
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Run ParaView

* You will be brought to the
V N C d es ktO p . TE\?@ X SEDE L:ghorn Visualization Portal

 In the white xterm, type
module load python
paraview

 You will receive no visual
feedback or return value

* This makes paraview
avallable on the
commandline.

1/20/2012 8
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Run ParaView

* Type vglrun paraview

« This will start paraview
and allow it to use the
system GPU for rendering

« By default, it does not
start up in parallel mode.
That has to be enabled
next.

- = . XSEDE\apb18 logout
TAGG XSEDE Longhorn Visualization Portal Rasuuee Logho (1031225
ime |ef. 5.50.16
Home | Allocations | Jobs | Rendering | Help

1/20/2012 9
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Run ParaView

* Click the “connect” button
( O r C h O O S e fl I e _ > C O n n e Ct) TA@@ x5 % E I.R::ghorn Visualization Portal
* This will bring up a B T
“choose a server” dialog. T T EET T R —
» Select “add server’

« Paraview can launch
backend parallel
processes for us and
connect to them, but we
need to configure it to do
SO.

eeeeeeeeeeeeeee

ssssssssssss

1/20/2012 10
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Run ParaView

* Once you click “add”, a
“configure new server” e A T
dialog will pop up. s TS R T

 Give it this configuration a @ fSacccarze 0 7T
name (e.g. “ibrun”) in the a e "
“name” field” e ?

« Leave the other fields i C =
alone !
— Server Type: Client/Server
— Host: Localhost e

— Port: 11111

* Click “configure”
1/20/2012 11
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Run ParaView

« A “configure server” dialog
Wi I I O p e n TAGG XSEDE Longhorn Visualization Portal Fosna Lo (o 122529

Home || Allcations | Jobs [ Rendarng | Help

L M ake Su re .Startu p Type: H@Eé y@ %5 ;w@ MH:’“ W K a > m DD @ m
Command is selected T T L T ——

 In the large text box, type

INn “env NO HOSTSORT=1 L.

— S
lbrun tacc xrun

” e ————— Pe——
pvserver me

— This is the command that
paraview will use to launch s
parallel backends

 Click “save”
1/20/2012

12
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Run ParaView

Select “Save Servers” to
ha.ve paraVieW remember EMAA@O;@ ?(pZSREdE!i;IL:nhghorn Visualization Portal
these settings

@ @@,_.e\ EIUE R R R com——

— Otherwise, you'll need to ERETTICIT ;},, - LI
type this information every - Q) e
time you restart paraview!
« It will prompt you for a s |
filename. Just type in e __
something like “servers”
and click OK S

Click “connect” to have
paraview launch the
vperallel backends. 13



Cornell University

Center for Advanced Computing

Run ParaView

 You will see several
Wl nd OWS pop u p th at TA@@ XSEFLonghorn Visualization Portal
report status.
pHE P EE 7 é}?ﬁ'é R KA DMB w1
« Once all backends have T TECT L T I ——

been launched, you can o P
close the status dialog
window if it's in the way.

« The number and location

(e
of backends s e
automatically determined :

by your initial settings
from submitting the VNC
1/}%1.2 14
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Parallel

« ParaView is now ready to
use. It looks no different
from “normal’

* The only visible
difference: the pipeline
browser now starts with
“cs://localhost:11111”

* You can proceed as
usual, ParaView will
automatically use all
available resources in
parallel.

1/20/2012

- [=ll=] %]
|| Longharn Visualization Pe 3\
& (& [ B pstgEportaLiongnarn tace utexas.edu RS
lacement ... % jasperpeilee.word.. ' VTG Brown Fleck .. ™ Bug 590880 —Tra.. [ Configuring CentQ... & AT&T Labs vs. Go... v

TAGG XSEDE Longhorn Visualization Portal

nnnnnnnnnnnnnnnnnnnnnnnnnnnnnn

cre

file Edit Yiew Sources Elters Tools Macros Help
pE %@ ER g T P S S B e —

PR I- I- Fix sk gan EeE -
IEDDEEEEERE
eeeeeeeeeeeeeee EX (EIRIEE]

1111111111111111111
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Parallel

« Select File->Open to load
th e eX am p I e d at a S et TMA?‘@ )iS%EM Longhorn Visualization Portal s oo b 12520

| options| cipbosra | 52 | Refrst]
* Navigate to —
pHEEEEE? MANRE X KA>PMHE mif_ T 5
/scratch/00832/envision/example data/ rE ‘ | s Xodbuaat BEE -
EEO i

® Load the mummy dataSet: “IP,DE.'MW“"‘T:: l/m::o sssssssssssssssssssss i e 6@ @l
mummy . vtk =

|

1/20/2012 16
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Parallel

« Once loaded, click “apply”
in the “properties” tab of
the object inspector

e EEoRE? @ALPER KA> PHE mil_ T B

« We will now add a filter T TR T TT TR ——
which augments this data =" [N
by adding another
variable representing
backend process ID for
each point. This will
Indicate which backend is D—
processing which portion
of the data.

1/20/2012 17
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Parallel

* In the “Filters” menu, go
d OW N to “ AI p h a b eti C a I ” TWA?‘@ %S’%EM Longhorn Visualization Portal Fovoe Lo 1 122528

Disconnect | Options || Clipboard | Send Ctri-Alt-Del | Refresh |
- - ] apb18 AMR Clip Integrate Variables surface Flow,
8] ParaView 3.8.1 64-b AMR Contour Interpolate to Quadrature Points Surface Vect
; = Ecem v | Append Attributes K Means Table To Stru
B ‘i% @ w | 9 (CETIRED » | Append Datasets Level scalars Temporal Ca
] Append Geornetr: Linear Extrusion Terporal Inte
m B i @sewe Somoesr o T
e n u S OW I n g a © @ § @ el anaysis Ceflanleiay Mask Foints Temporal snz
Statistics » | Cell Centers Material Interface Filrer Temporal Sta
- . - Plpeline Browser | g opa) v | cell Data to Foint Data Median Tessellate
1111 o Clean Merge Blocks Tetrahedraliz
Clean to Grid Mesh Quality Texture Map
n I3 ciip Multicorrelative Statistics Texture Map
Compute Derivatives [ normal Glyphs Texture Map
11 Connectivity Octree Depth Limit B Threshold
to t h e P ro Ce S S I d Contingency Statistics Octree Depth Scalars Transform
Contour Outline Triangle Strips
P & Cosmology Halo Finder Outline Comers Tiangulate
Curvature Outline Curvilinear Dataset Tube
” . QCBETES B Particle Pathlines Warp By Scal
S Ca I a rS fl Ite r a n d Ch Oose @iecer (8 Delete Decimate FarticleTracer ¥ warp By vect
Delaunay 20 Plot Data
Delaunay 30 Flot Global Variables Over Time
- Descriptive Statistics [ Plot On Intersection Curves
Elevation Plot On Sorted Lines
I t Extract AMR Blocks B Plot Over Line
L} Extract Block 1 Flot Selection Over Time
(Bl EUln (s Point Data to Cell Data
Extract Cells By Region Principal Component Analysis
Extract Edges
8 Extract Level Process Id Scalars
A Extract Selection
[ Extract Subset Python Calcuiator
Extract Surface Quadric Clustering
ks [ FFT OF Selection Over Time Randorm Vectors
Feature Edges Rectilinear Grid Connectivity
Generate Ids Reflect
Generate Quadrature Foints Resample with Dataset

1/20/2012 18
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* Click “apply” in the
properties tab of the TEO0 XEEEE e ) =5
object inspector for the e

. pEEEosaE? &
ProcessID Scalars filter. AR

ENCOoEECE=R

[T

o SR O T r— -
melk iR sdEsas Flga -

1/20/2012 19
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Parallel

* (o to the “information™ tab
of the object Inspector for ~TACEXSERE tormom st or
the ProcessID Scalars e e — :
filter. Scroll down until @:@@;r.g
you can see the "Data @ [ i
Arrays” section.

* Observe that there is a
new array named
“Processld” containing
iIntegers ranging from 0-7.

— These values map to our
eight backend servers.

1/20/2012 20
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Parallel

« Add and apply a contour
filter via Filters -> T e =
Common -> Contour e —

 We will use this to - ENagm
produce an isosurface of
the mummy skull where
the value is 128.

« We will color this surface F?’%ﬁf aaaaa —
by Processld e

« Be sure to click “Apply”
after selecting the Contour
filter.

1/20/2012 21
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Parallel

* In the “properties” tab of
the object inspector for Lonlmn R e
the contour filter, find the === -—S
“contour section” e e 3 4 55 i HRE

« The value will likely be
“Processld” change it to
“scalars” :

— We want to use the
“scalars” data to produce

the surface.

1/20/2012 22
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Parallel

 Still in the “properties” tab,
scroll down to the e e I
“Isosurfaces” section. T :
Delete the existing value [l === " L TR
(probably) 3.5, and add a
new value of 128.

1/20/2012 23
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Parallel

« When finished, you should
have a single value of e ek
“128" selected. ; "

« Click “Apply”.

* Go to the "Display” tab
and in the “color” section, e
verify that “Processld” is . | =2 -
selected in the “Color by” *
selector.

ile  Edit Yiew Sources [ifters TJools Macros Help
pHEERoRE? BAHDREE KArBHE m_— T 8
resentationnls < 38 i B B A8 ol i IE'@‘ 8 -

1/20/2012 24
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Parallel

* You should now see a
rendering where the e e ——
contour surface is B s
determined by the ori g inal S A o .4;

data, but colored by o
process ID.

* Since we have 2 nodes at
4 processes per node, we
should see 8 distinct e —
colors. This is showing ‘ " C—
data parallelism.

1/20/2012 25
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Parallel

« ParaView will
automatically determine if
backends perform data D e R
processing only (sending |iia o
triangles for client to
render), or perform
rendering as well (send
the pixels to directly
display).

* This can be tweaked via
Edit->Settings->Render

View->Server
1/20/2012 26
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Experiment!

* Try applying the tetrahedralize filter, viewing by volume,
looking at memory usage, tweaking remote rendering
threshold in settings

« Load the other dataset in the examples directory

(isotropic.vtk), try plotting streamlines and coloring by
process lds

* Try running Vislt in parallel mode.

1/20/2012 27



